CentOS7にyumでLet’sEncriptをインストールする

インストール

[root@localhost ~]# yum install certbot python2-certbot-apache
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * base: ftp-srv2.kddilabs.jp
 * epel: ftp.jaist.ac.jp
 * extras: ftp-srv2.kddilabs.jp
 * remi-safe: ftp.riken.jp
 * updates: ftp-srv2.kddilabs.jp
Resolving Dependencies
--> Running transaction check
---> Package certbot.noarch 0:0.34.2-3.el7 will be installed
--> Processing Dependency: python2-certbot = 0.34.2-3.el7 for package: certbot-0.34.2-3.el7.noarch
--> Processing Dependency: /usr/sbin/semanage for package: certbot-0.34.2-3.el7.noarch
---> Package python2-certbot-apache.noarch 0:0.34.2-1.el7 will be installed
--> Processing Dependency: python2-acme >= 0.29.0 for package: python2-certbot-apache-0.34.2-1.el7.noarch
--> Processing Dependency: pytest for package: python2-certbot-apache-0.34.2-1.el7.noarch
--> Running transaction check
---> Package policycoreutils-python.x86_64 0:2.5-29.el7_6.1 will be installed
--> Processing Dependency: setools-libs >= 3.3.8-4 for package: policycoreutils-python-2.5-29.el7_6.1.x86_64
--> Processing Dependency: libsemanage-python >= 2.5-14 for package: policycoreutils-python-2.5-29.el7_6.1.x86_64
--> Processing Dependency: audit-libs-python >= 2.1.3-4 for package: policycoreutils-python-2.5-29.el7_6.1.x86_64
--> Processing Dependency: python-IPy for package: policycoreutils-python-2.5-29.el7_6.1.x86_64
--> Processing Dependency: libqpol.so.1(VERS_1.4)(64bit) for package: policycoreutils-python-2.5-29.el7_6.1.x86_64
--> Processing Dependency: libqpol.so.1(VERS_1.2)(64bit) for package: policycoreutils-python-2.5-29.el7_6.1.x86_64
--> Processing Dependency: libcgroup for package: policycoreutils-python-2.5-29.el7_6.1.x86_64
--> Processing Dependency: libapol.so.4(VERS_4.0)(64bit) for package: policycoreutils-python-2.5-29.el7_6.1.x86_64
--> Processing Dependency: checkpolicy for package: policycoreutils-python-2.5-29.el7_6.1.x86_64
--> Processing Dependency: libqpol.so.1()(64bit) for package: policycoreutils-python-2.5-29.el7_6.1.x86_64
--> Processing Dependency: libapol.so.4()(64bit) for package: policycoreutils-python-2.5-29.el7_6.1.x86_64
---> Package pytest.noarch 0:2.7.0-2.el7 will be installed
--> Processing Dependency: python-py >= 1.4.25 for package: pytest-2.7.0-2.el7.noarch
---> Package python2-acme.noarch 0:0.34.2-1.el7 will be installed
--> Processing Dependency: pyOpenSSL >= 0.13.1 for package: python2-acme-0.34.2-1.el7.noarch
--> Processing Dependency: python2-josepy >= 1.1.0 for package: python2-acme-0.34.2-1.el7.noarch
--> Processing Dependency: python-ndg_httpsclient for package: python2-acme-0.34.2-1.el7.noarch
--> Processing Dependency: python-requests-toolbelt for package: python2-acme-0.34.2-1.el7.noarch
--> Processing Dependency: python2-cryptography for package: python2-acme-0.34.2-1.el7.noarch
--> Processing Dependency: python2-pyasn1 for package: python2-acme-0.34.2-1.el7.noarch
--> Processing Dependency: python2-pyrfc3339 for package: python2-acme-0.34.2-1.el7.noarch
--> Processing Dependency: python2-requests for package: python2-acme-0.34.2-1.el7.noarch
--> Processing Dependency: python2-six for package: python2-acme-0.34.2-1.el7.noarch
--> Processing Dependency: pytz for package: python2-acme-0.34.2-1.el7.noarch
---> Package python2-certbot.noarch 0:0.34.2-3.el7 will be installed
--> Processing Dependency: python-parsedatetime for package: python2-certbot-0.34.2-3.el7.noarch
--> Processing Dependency: python-zope-component for package: python2-certbot-0.34.2-3.el7.noarch
--> Processing Dependency: python-zope-interface for package: python2-certbot-0.34.2-3.el7.noarch
--> Processing Dependency: python2-configargparse for package: python2-certbot-0.34.2-3.el7.noarch
--> Processing Dependency: python2-future for package: python2-certbot-0.34.2-3.el7.noarch
--> Processing Dependency: python2-mock for package: python2-certbot-0.34.2-3.el7.noarch
--> Running transaction check
---> Package audit-libs-python.x86_64 0:2.8.4-4.el7 will be installed
---> Package checkpolicy.x86_64 0:2.5-8.el7 will be installed
---> Package libcgroup.x86_64 0:0.41-20.el7 will be installed
---> Package libsemanage-python.x86_64 0:2.5-14.el7 will be installed
---> Package pyOpenSSL.x86_64 0:0.13.1-4.el7 will be installed
---> Package python-IPy.noarch 0:0.75-6.el7 will be installed
---> Package python-ndg_httpsclient.noarch 0:0.3.2-1.el7 will be installed
---> Package python-py.noarch 0:1.4.32-1.el7 will be installed
---> Package python-requests-toolbelt.noarch 0:0.8.0-1.el7 will be installed
--> Processing Dependency: python-requests for package: python-requests-toolbelt-0.8.0-1.el7.noarch
---> Package python-zope-component.noarch 1:4.1.0-5.el7 will be installed
--> Processing Dependency: python-zope-event for package: 1:python-zope-component-4.1.0-5.el7.noarch
---> Package python-zope-interface.x86_64 0:4.0.5-4.el7 will be installed
---> Package python2-configargparse.noarch 0:0.11.0-1.el7 will be installed
---> Package python2-cryptography.x86_64 0:1.7.2-2.el7 will be installed
--> Processing Dependency: python-idna >= 2.0 for package: python2-cryptography-1.7.2-2.el7.x86_64
--> Processing Dependency: python-cffi >= 1.4.1 for package: python2-cryptography-1.7.2-2.el7.x86_64
--> Processing Dependency: python-enum34 for package: python2-cryptography-1.7.2-2.el7.x86_64
---> Package python2-future.noarch 0:0.16.0-15.20181019gitbee0f3b.el7 will be installed
---> Package python2-josepy.noarch 0:1.1.0-1.el7 will be installed
---> Package python2-mock.noarch 0:1.0.1-10.el7 will be installed
---> Package python2-parsedatetime.noarch 0:2.4-5.el7 will be installed
---> Package python2-pyasn1.noarch 0:0.1.9-7.el7 will be installed
---> Package python2-pyrfc3339.noarch 0:1.0-2.el7 will be installed
---> Package python2-requests.noarch 0:2.6.0-0.el7 will be installed
---> Package python2-six.noarch 0:1.9.0-0.el7 will be installed
---> Package pytz.noarch 0:2016.10-2.el7 will be installed
---> Package setools-libs.x86_64 0:3.3.8-4.el7 will be installed
--> Running transaction check
---> Package python-cffi.x86_64 0:1.6.0-5.el7 will be installed
--> Processing Dependency: python-pycparser for package: python-cffi-1.6.0-5.el7.x86_64
---> Package python-enum34.noarch 0:1.0.4-1.el7 will be installed
---> Package python-idna.noarch 0:2.4-1.el7 will be installed
---> Package python-requests.noarch 0:2.6.0-1.el7_1 will be installed
--> Processing Dependency: python-urllib3 >= 1.10.2-1 for package: python-requests-2.6.0-1.el7_1.noarch
---> Package python-zope-event.noarch 0:4.0.3-2.el7 will be installed
--> Running transaction check
---> Package python-pycparser.noarch 0:2.14-1.el7 will be installed
--> Processing Dependency: python-ply for package: python-pycparser-2.14-1.el7.noarch
---> Package python-urllib3.noarch 0:1.10.2-5.el7 will be installed
--> Running transaction check
---> Package python-ply.noarch 0:3.4-11.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

=====================================================================================================================
 Package                           Arch            Version                                    Repository        Size
=====================================================================================================================
Installing:
 certbot                           noarch          0.34.2-3.el7                               epel              39 k
 python2-certbot-apache            noarch          0.34.2-1.el7                               epel             240 k
Installing for dependencies:
 audit-libs-python                 x86_64          2.8.4-4.el7                                base              76 k
 checkpolicy                       x86_64          2.5-8.el7                                  base             295 k
 libcgroup                         x86_64          0.41-20.el7                                base              66 k
 libsemanage-python                x86_64          2.5-14.el7                                 base             113 k
 policycoreutils-python            x86_64          2.5-29.el7_6.1                             updates          456 k
 pyOpenSSL                         x86_64          0.13.1-4.el7                               base             135 k
 pytest                            noarch          2.7.0-2.el7                                base             757 k
 python-IPy                        noarch          0.75-6.el7                                 base              32 k
 python-cffi                       x86_64          1.6.0-5.el7                                base             218 k
 python-enum34                     noarch          1.0.4-1.el7                                base              52 k
 python-idna                       noarch          2.4-1.el7                                  base              94 k
 python-ndg_httpsclient            noarch          0.3.2-1.el7                                epel              43 k
 python-ply                        noarch          3.4-11.el7                                 base             123 k
 python-py                         noarch          1.4.32-1.el7                               base             341 k
 python-pycparser                  noarch          2.14-1.el7                                 base             104 k
 python-requests                   noarch          2.6.0-1.el7_1                              base              94 k
 python-requests-toolbelt          noarch          0.8.0-1.el7                                epel              77 k
 python-urllib3                    noarch          1.10.2-5.el7                               base             102 k
 python-zope-component             noarch          1:4.1.0-5.el7                              epel             228 k
 python-zope-event                 noarch          4.0.3-2.el7                                epel              79 k
 python-zope-interface             x86_64          4.0.5-4.el7                                base             138 k
 python2-acme                      noarch          0.34.2-1.el7                               epel             149 k
 python2-certbot                   noarch          0.34.2-3.el7                               epel             556 k
 python2-configargparse            noarch          0.11.0-1.el7                               epel              30 k
 python2-cryptography              x86_64          1.7.2-2.el7                                base             502 k
 python2-future                    noarch          0.16.0-15.20181019gitbee0f3b.el7           epel             802 k
 python2-josepy                    noarch          1.1.0-1.el7                                epel              87 k
 python2-mock                      noarch          1.0.1-10.el7                               epel              92 k
 python2-parsedatetime             noarch          2.4-5.el7                                  epel              78 k
 python2-pyasn1                    noarch          0.1.9-7.el7                                base             100 k
 python2-pyrfc3339                 noarch          1.0-2.el7                                  epel              13 k
 python2-requests                  noarch          2.6.0-0.el7                                epel             2.9 k
 python2-six                       noarch          1.9.0-0.el7                                epel             2.9 k
 pytz                              noarch          2016.10-2.el7                              base              46 k
 setools-libs                      x86_64          3.3.8-4.el7                                base             620 k

Transaction Summary
=====================================================================================================================
Install  2 Packages (+35 Dependent packages)

Total download size: 6.8 M
Installed size: 31 M
Is this ok [y/d/N]: y
Downloading packages:
(1/37): certbot-0.34.2-3.el7.noarch.rpm                                                       |  39 kB  00:00:00
(2/37): audit-libs-python-2.8.4-4.el7.x86_64.rpm                                              |  76 kB  00:00:00
(3/37): libcgroup-0.41-20.el7.x86_64.rpm                                                      |  66 kB  00:00:00
(4/37): libsemanage-python-2.5-14.el7.x86_64.rpm                                              | 113 kB  00:00:00
(5/37): checkpolicy-2.5-8.el7.x86_64.rpm                                                      | 295 kB  00:00:00
(6/37): python-IPy-0.75-6.el7.noarch.rpm                                                      |  32 kB  00:00:00
(7/37): python-enum34-1.0.4-1.el7.noarch.rpm                                                  |  52 kB  00:00:00
(8/37): pyOpenSSL-0.13.1-4.el7.x86_64.rpm                                                     | 135 kB  00:00:00
(9/37): python-idna-2.4-1.el7.noarch.rpm                                                      |  94 kB  00:00:00
(10/37): python-ndg_httpsclient-0.3.2-1.el7.noarch.rpm                                        |  43 kB  00:00:00
(11/37): python-cffi-1.6.0-5.el7.x86_64.rpm                                                   | 218 kB  00:00:00
(12/37): python-ply-3.4-11.el7.noarch.rpm                                                     | 123 kB  00:00:00
(13/37): policycoreutils-python-2.5-29.el7_6.1.x86_64.rpm                                     | 456 kB  00:00:00
(14/37): python-pycparser-2.14-1.el7.noarch.rpm                                               | 104 kB  00:00:00
(15/37): python-requests-2.6.0-1.el7_1.noarch.rpm                                             |  94 kB  00:00:00
(16/37): python-requests-toolbelt-0.8.0-1.el7.noarch.rpm                                      |  77 kB  00:00:00
(17/37): python-urllib3-1.10.2-5.el7.noarch.rpm                                               | 102 kB  00:00:00
(18/37): python-zope-event-4.0.3-2.el7.noarch.rpm                                             |  79 kB  00:00:00
(19/37): python-py-1.4.32-1.el7.noarch.rpm                                                    | 341 kB  00:00:00
(20/37): python-zope-interface-4.0.5-4.el7.x86_64.rpm                                         | 138 kB  00:00:00
(21/37): python2-acme-0.34.2-1.el7.noarch.rpm                                                 | 149 kB  00:00:00
(22/37): python-zope-component-4.1.0-5.el7.noarch.rpm                                         | 228 kB  00:00:00
(23/37): python2-certbot-0.34.2-3.el7.noarch.rpm                                              | 556 kB  00:00:00
(24/37): python2-configargparse-0.11.0-1.el7.noarch.rpm                                       |  30 kB  00:00:00
(25/37): python2-certbot-apache-0.34.2-1.el7.noarch.rpm                                       | 240 kB  00:00:00
(26/37): python2-josepy-1.1.0-1.el7.noarch.rpm                                                |  87 kB  00:00:00
(27/37): pytest-2.7.0-2.el7.noarch.rpm                                                        | 757 kB  00:00:00
(28/37): python2-future-0.16.0-15.20181019gitbee0f3b.el7.noarch.rpm                           | 802 kB  00:00:00
(29/37): python2-pyasn1-0.1.9-7.el7.noarch.rpm                                                | 100 kB  00:00:00
(30/37): python2-mock-1.0.1-10.el7.noarch.rpm                                                 |  92 kB  00:00:00
(31/37): python2-cryptography-1.7.2-2.el7.x86_64.rpm                                          | 502 kB  00:00:00
(32/37): python2-parsedatetime-2.4-5.el7.noarch.rpm                                           |  78 kB  00:00:00
(33/37): python2-pyrfc3339-1.0-2.el7.noarch.rpm                                               |  13 kB  00:00:00
(34/37): python2-requests-2.6.0-0.el7.noarch.rpm                                              | 2.9 kB  00:00:00
(35/37): python2-six-1.9.0-0.el7.noarch.rpm                                                   | 2.9 kB  00:00:00
(36/37): setools-libs-3.3.8-4.el7.x86_64.rpm                                                  | 620 kB  00:00:00
(37/37): pytz-2016.10-2.el7.noarch.rpm                                                        |  46 kB  00:00:00
---------------------------------------------------------------------------------------------------------------------
Total                                                                                4.5 MB/s | 6.8 MB  00:00:01
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : python2-pyasn1-0.1.9-7.el7.noarch                                                                1/37
  Installing : pyOpenSSL-0.13.1-4.el7.x86_64                                                                    2/37
  Installing : python-zope-interface-4.0.5-4.el7.x86_64                                                         3/37
  Installing : python2-future-0.16.0-15.20181019gitbee0f3b.el7.noarch                                           4/37
  Installing : pytz-2016.10-2.el7.noarch                                                                        5/37
  Installing : python2-pyrfc3339-1.0-2.el7.noarch                                                               6/37
  Installing : python2-parsedatetime-2.4-5.el7.noarch                                                           7/37
  Installing : python-ndg_httpsclient-0.3.2-1.el7.noarch                                                        8/37
  Installing : python-zope-event-4.0.3-2.el7.noarch                                                             9/37
  Installing : 1:python-zope-component-4.1.0-5.el7.noarch                                                      10/37
  Installing : audit-libs-python-2.8.4-4.el7.x86_64                                                            11/37
  Installing : libsemanage-python-2.5-14.el7.x86_64                                                            12/37
  Installing : python-ply-3.4-11.el7.noarch                                                                    13/37
  Installing : python-pycparser-2.14-1.el7.noarch                                                              14/37
  Installing : python-cffi-1.6.0-5.el7.x86_64                                                                  15/37
  Installing : python-idna-2.4-1.el7.noarch                                                                    16/37
  Installing : setools-libs-3.3.8-4.el7.x86_64                                                                 17/37
  Installing : python-urllib3-1.10.2-5.el7.noarch                                                              18/37
  Installing : python-requests-2.6.0-1.el7_1.noarch                                                            19/37
  Installing : python-requests-toolbelt-0.8.0-1.el7.noarch                                                     20/37
  Installing : python2-requests-2.6.0-0.el7.noarch                                                             21/37
  Installing : python-IPy-0.75-6.el7.noarch                                                                    22/37
  Installing : python2-configargparse-0.11.0-1.el7.noarch                                                      23/37
  Installing : python2-mock-1.0.1-10.el7.noarch                                                                24/37
  Installing : checkpolicy-2.5-8.el7.x86_64                                                                    25/37
  Installing : python-enum34-1.0.4-1.el7.noarch                                                                26/37
  Installing : python2-cryptography-1.7.2-2.el7.x86_64                                                         27/37
  Installing : python2-josepy-1.1.0-1.el7.noarch                                                               28/37
  Installing : python-py-1.4.32-1.el7.noarch                                                                   29/37
  Installing : pytest-2.7.0-2.el7.noarch                                                                       30/37
  Installing : python2-six-1.9.0-0.el7.noarch                                                                  31/37
  Installing : python2-acme-0.34.2-1.el7.noarch                                                                32/37
  Installing : python2-certbot-0.34.2-3.el7.noarch                                                             33/37
  Installing : libcgroup-0.41-20.el7.x86_64                                                                    34/37
  Installing : policycoreutils-python-2.5-29.el7_6.1.x86_64                                                    35/37
  Installing : certbot-0.34.2-3.el7.noarch                                                                     36/37
  Installing : python2-certbot-apache-0.34.2-1.el7.noarch                                                      37/37
  Verifying  : libcgroup-0.41-20.el7.x86_64                                                                     1/37
  Verifying  : python2-six-1.9.0-0.el7.noarch                                                                   2/37
  Verifying  : python2-certbot-0.34.2-3.el7.noarch                                                              3/37
  Verifying  : python-py-1.4.32-1.el7.noarch                                                                    4/37
  Verifying  : python-requests-toolbelt-0.8.0-1.el7.noarch                                                      5/37
  Verifying  : python-enum34-1.0.4-1.el7.noarch                                                                 6/37
  Verifying  : 1:python-zope-component-4.1.0-5.el7.noarch                                                       7/37
  Verifying  : checkpolicy-2.5-8.el7.x86_64                                                                     8/37
  Verifying  : python2-pyrfc3339-1.0-2.el7.noarch                                                               9/37
  Verifying  : python2-mock-1.0.1-10.el7.noarch                                                                10/37
  Verifying  : python2-configargparse-0.11.0-1.el7.noarch                                                      11/37
  Verifying  : pytz-2016.10-2.el7.noarch                                                                       12/37
  Verifying  : python-IPy-0.75-6.el7.noarch                                                                    13/37
  Verifying  : python-urllib3-1.10.2-5.el7.noarch                                                              14/37
  Verifying  : python-ndg_httpsclient-0.3.2-1.el7.noarch                                                       15/37
  Verifying  : setools-libs-3.3.8-4.el7.x86_64                                                                 16/37
  Verifying  : python-idna-2.4-1.el7.noarch                                                                    17/37
  Verifying  : python2-acme-0.34.2-1.el7.noarch                                                                18/37
  Verifying  : python-ply-3.4-11.el7.noarch                                                                    19/37
  Verifying  : policycoreutils-python-2.5-29.el7_6.1.x86_64                                                    20/37
  Verifying  : python2-requests-2.6.0-0.el7.noarch                                                             21/37
  Verifying  : libsemanage-python-2.5-14.el7.x86_64                                                            22/37
  Verifying  : python-cffi-1.6.0-5.el7.x86_64                                                                  23/37
  Verifying  : pytest-2.7.0-2.el7.noarch                                                                       24/37
  Verifying  : pyOpenSSL-0.13.1-4.el7.x86_64                                                                   25/37
  Verifying  : certbot-0.34.2-3.el7.noarch                                                                     26/37
  Verifying  : python2-parsedatetime-2.4-5.el7.noarch                                                          27/37
  Verifying  : audit-libs-python-2.8.4-4.el7.x86_64                                                            28/37
  Verifying  : python-pycparser-2.14-1.el7.noarch                                                              29/37
  Verifying  : python2-josepy-1.1.0-1.el7.noarch                                                               30/37
  Verifying  : python-requests-2.6.0-1.el7_1.noarch                                                            31/37
  Verifying  : python-zope-event-4.0.3-2.el7.noarch                                                            32/37
  Verifying  : python2-pyasn1-0.1.9-7.el7.noarch                                                               33/37
  Verifying  : python2-future-0.16.0-15.20181019gitbee0f3b.el7.noarch                                          34/37
  Verifying  : python-zope-interface-4.0.5-4.el7.x86_64                                                        35/37
  Verifying  : python2-certbot-apache-0.34.2-1.el7.noarch                                                      36/37
  Verifying  : python2-cryptography-1.7.2-2.el7.x86_64                                                         37/37

Installed:
  certbot.noarch 0:0.34.2-3.el7                     python2-certbot-apache.noarch 0:0.34.2-1.el7

Dependency Installed:
  audit-libs-python.x86_64 0:2.8.4-4.el7               checkpolicy.x86_64 0:2.5-8.el7
  libcgroup.x86_64 0:0.41-20.el7                       libsemanage-python.x86_64 0:2.5-14.el7
  policycoreutils-python.x86_64 0:2.5-29.el7_6.1       pyOpenSSL.x86_64 0:0.13.1-4.el7
  pytest.noarch 0:2.7.0-2.el7                          python-IPy.noarch 0:0.75-6.el7
  python-cffi.x86_64 0:1.6.0-5.el7                     python-enum34.noarch 0:1.0.4-1.el7
  python-idna.noarch 0:2.4-1.el7                       python-ndg_httpsclient.noarch 0:0.3.2-1.el7
  python-ply.noarch 0:3.4-11.el7                       python-py.noarch 0:1.4.32-1.el7
  python-pycparser.noarch 0:2.14-1.el7                 python-requests.noarch 0:2.6.0-1.el7_1
  python-requests-toolbelt.noarch 0:0.8.0-1.el7        python-urllib3.noarch 0:1.10.2-5.el7
  python-zope-component.noarch 1:4.1.0-5.el7           python-zope-event.noarch 0:4.0.3-2.el7
  python-zope-interface.x86_64 0:4.0.5-4.el7           python2-acme.noarch 0:0.34.2-1.el7
  python2-certbot.noarch 0:0.34.2-3.el7                python2-configargparse.noarch 0:0.11.0-1.el7
  python2-cryptography.x86_64 0:1.7.2-2.el7            python2-future.noarch 0:0.16.0-15.20181019gitbee0f3b.el7
  python2-josepy.noarch 0:1.1.0-1.el7                  python2-mock.noarch 0:1.0.1-10.el7
  python2-parsedatetime.noarch 0:2.4-5.el7             python2-pyasn1.noarch 0:0.1.9-7.el7
  python2-pyrfc3339.noarch 0:1.0-2.el7                 python2-requests.noarch 0:2.6.0-0.el7
  python2-six.noarch 0:1.9.0-0.el7                     pytz.noarch 0:2016.10-2.el7
  setools-libs.x86_64 0:3.3.8-4.el7

Complete!
[root@localhost ~]#

[root@localhost conf.d]# certbot --apache -d dennou-lab.com
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator apache, Installer apache
Starting new HTTPS connection (1): acme-v02.api.letsencrypt.org
Cert is due for renewal, auto-renewing...
Renewing an existing certificate
Performing the following challenges:
http-01 challenge for dennou-lab.com
Cleaning up challenges
Unable to find a virtual host listening on port 80 which is currently needed for Certbot to prove to the CA that you control your domain. Please add a virtual host for port 80.
[root@localhost conf.d]# vi /etc/httpd/conf/httpd.conf

以下をファイルの末尾に追加
------------------------------
NameVirtualHost *:80

<VirtualHost *:80>
    ServerAdmin root@dennou-lab.com
    DocumentRoot /var/www/html
    ServerName dennou-lab.com
</VirtualHost>
------------------------------

[root@localhost conf.d]# certbot --apache -d dennou-lab.com
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator apache, Installer apache
Starting new HTTPS connection (1): acme-v02.api.letsencrypt.org
Cert is due for renewal, auto-renewing...
Renewing an existing certificate
Performing the following challenges:
http-01 challenge for dennou-lab.com
Waiting for verification...
Cleaning up challenges
Created an SSL vhost at /etc/httpd/conf/httpd-le-ssl.conf
Deploying Certificate to VirtualHost /etc/httpd/conf/httpd-le-ssl.conf
Enabling site /etc/httpd/conf/httpd-le-ssl.conf by adding Include to root configuration

Please choose whether or not to redirect HTTP traffic to HTTPS, removing HTTP access.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
1: No redirect - Make no further changes to the webserver configuration.
2: Redirect - Make all requests redirect to secure HTTPS access. Choose this for
new sites, or if you're confident your site works on HTTPS. You can undo this
change by editing your web server's configuration.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Select the appropriate number [1-2] then [enter] (press 'c' to cancel): 2
Redirecting vhost in /etc/httpd/conf/httpd.conf to ssl vhost in /etc/httpd/conf/httpd-le-ssl.conf

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Your existing certificate has been successfully renewed, and the new certificate
has been installed.

The new certificate covers the following domains: https://dennou-lab.com

You should test your configuration at:
https://www.ssllabs.com/ssltest/analyze.html?d=dennou-lab.com
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

IMPORTANT NOTES:
 - Congratulations! Your certificate and chain have been saved at:
   /etc/letsencrypt/live/dennou-lab.com/fullchain.pem
   Your key file has been saved at:
   /etc/letsencrypt/live/dennou-lab.com/privkey.pem
   Your cert will expire on 2019-09-13. To obtain a new or tweaked
   version of this certificate in the future, simply run certbot again
   with the "certonly" option. To non-interactively renew *all* of
   your certificates, run "certbot renew"
 - If you like Certbot, please consider supporting our work by:

   Donating to ISRG / Let's Encrypt:   https://letsencrypt.org/donate
   Donating to EFF:                    https://eff.org/donate-le

[root@localhost conf.d]#

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です